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400 CHAPTER 15 Basic Site Management Tools

        
The Project Tab of the Palette

The Project tab includes groups, that is, containers for similar objects 
that help you clean up your Project window. 

The following table lists the individual tags in the Project tab and ex-
plains how to use them.

Drag any icon from the Palette and drop it on the 
respective tab of the Project window to insert a 
generic element.



 

401Creating a Project
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403Importing Pages and Resources
To add pages or resources to the project using the Add Files com-
mand, proceed as follows:

1 Choose the Add Files command from the Project menu.

The Add Files Dialog Box

2 In the subsequent file selection dialog box, click to select a file or 
folder from the list box in the upper left corner.

3 If desired, click Create to have GoLive CyberStudio build a pre-
view of an image or the title frame of a movie.

4 Click Add to add a single file to the Select items to add… list, click 
Add Folder to add a folder,
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7 Choose the Paste command from the Edit menu or press 
Command-V to paste the URL from the clipboard, overwriting the 
generic URL in the URL text box.

8 Press the Return key to confirm your entry.

9 Place the cursor in the Name text box, name the new URL (over-
writing the generic Untitled URL name) and press the Return key 
to confirm your entry. 

To import a bookmark file, address book, or plain text file using the 
Import File command, proceed as follows:

1 Go to the Project menu and choose Import File.

The Import File Dialog Box

2 In the subsequent file selection dialog box, click to select a file 
from the list box.

You can impor
/F10 764 0 TD
(t an)Tj
1.665 0 TD
(y bookmar)Tj
4..
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407Importing Pages and Resources
The Color Inspector 

Alternatively,



408 CHAPTER 15 Importing Pages and Resources
• Any selected item in the Colors tab can be renamed by placing the 
cursor in the Name text box of the Color Inspector or Color Group 
Inspector, editing the name and pr









412 CHAPTER 15 Importing Pages and Resources
Choosing the Project Switch List 
from the Project Menu

4 Choose the Paste command from the Edit menu (or press Com-
mand-V). When you drop the font set, it will be added to the list 
under the same name as in the source project.



413Importing Pages and Resources
Setting Up the Project 
in the Project Inspector

Choosing a Home Page

When you are done importing resources and files, choose the Project 
Inspector to defiour4 home page. 

Because the home page is the highest-ranking page in the hi
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417Managing Files Using the Reference Inspector
3 Click the New button in the lower right corner of the tab to en-
able the text box. 

4 Type in a filename fragment and press the Return key to confirm 
your entry. GoLive CyberStudio will ignore all files with that frag-
ment in their filenames.

5 Repeat steps 3 and 4 for all file types that you wish GoLive Cyber-
Studio to ignore.

6 Click the Delete button to delete a selected exception.

7 When you are done defining exceptions, click the Update Project 
button to have GoLive CyberStudio reparse the project and reset 
the error messages accordingly. 

Managing Files Using 
the Reference 
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421Managing Files Using the Reference Inspector
To view basic file informar e Finder-related settings, pro-
ceed as follows:

1 With the Web page still selected, click the File ab rider of the Ref-
erence Inspector.

The File Tab of the Reference Inspector

2 You can make two Finder-related settings:

- Choose a Finder label from the Label popup menu. The color 
field next to the  popup menu will change to the color 

of the new Finder label.

- Check the  checkbox if you wish to reuse the file as 
a template for other pages.

3 You can also view file-related informaTj
12from the Finder:

- Created shows the date and time when the current file was 
saved first.

- Modified shows the date and time when the current file was 
saved last.

- Size shows the amount of disk space (in kilobytes) the current 
file occupies 
12your hard disk.

- Type and Creator are the codes your Macintosh uses to iden-
tify files created by GoLive CyberStudio.
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To preview an HTML page, proceed as follows:

1 With the Web page still selected, click the Content tab rider of the 
Reference Inspector.

2 A detailed preview of the HTML page appears in the preview pane 
of the Content tab.
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To preview an image or a media file, proceed as follows:

1 With the image or media file selected in the Project window, click 
the Content tab rider of the Reference Inspector.

The Content Tab of the Reference 
C368 Re612 Ta
(o pr506tent )Tj
/F8 e mile
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T
t
U

8 Click Change to update all files. 

Inspecting the MCF File 

The Reference Inspector lets you inspect the MCF file of your Project, 
allowing you to obtain general file information from the Finder and 
fly through a three-dimensional representation of your site.

To inspect the MCF file, proceed as follows:

1 Make sure that the Create/Update MCF file on project save checkbox 
is checked in the Project - General tab of the Preferences dialog 
(see page 459).

Alternatively, you can select a page in the Project window and 
choose the Create HotSauce… command from the Project 
h e  m a i n  d i s p l a y  a r e a  o f  t h e  C o n t e n t  t a b  s h o w s  a  
h r e e - d i m e n s i o n a l  f l y - t h r o u g h  v i e w  o f  y o u r  s i t e .
s e  t h i s  o n - s c r e e n  m e n u  t o  c o n t r o l  t h e  d i s p l a y .
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eg thedisplay, selpecg ther screen menu.8









432 CHAPTER 15 Viewing Your Site
The Graphics Inspector Accompanying the Site View is a context-sensitive Inspector window 
thi t lets you build the site view, zoom in and out of the graphic, and 
adjust various display properties, such as grid width, geometry, and 
color.

The Graphics Inspector

To control the following display options in the Site View, proceed as 
follows:
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The Link View Tab
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The Link View Inspector

1 Uncheck the appropriate checkbox to hide that item. 

2 Check the appropriate checkbox to show that item.

3 Check the Icon instead of thumbnail

previewing off.

The f ollowing example shows a Link Vie w  with HTML Þ les onl y .Viewing Referenced Pages in the 

Link View

ou vie w the 

esour ces. Conver sel y , y ou 

t the curr ent 

w , pr oceed as f ollows:

1 Select the page you wish to view in the Site View  tab.

2 Click the Link View  tab to display the selected page and its links.

Use these options to show or hide entire classes 

of objects.

Click here to hide or show forward links.

Click here to hide or show backward links.

{

C lick here to toggle the thumbnail display in the 

Link View on and off.
T o show or hide a class of  objects, pr oceed as f ollows:

Z ooming in on Pag es

GoLi ve CyberStudio Õ s a bility to zoom in on a page lets y

r efer ences it mak es to other pages and to r

can also inspect the links fr om other pages pointing a

page.

T o zoom in on a page in the Link Vie
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progressively—starting at the home page and working your way 
through all levels of the hierarchy.
Alternatively, you can also zoom in on a page from the Project win-
dow:

1 Select the page you wish to view in the Project window.

2 Choose the Show Site command from the Project menu.

3 In the Site View window, click the Link View tab to display the se-
lected page and its links.

Zooming in on Resources

As with pages, you can also zoom in on individual resources, such as 
image files, to check where they are being used in your site.

Viewing a Resource in the Link View

To zoom in on a resource in the Link View, proceed as follows:

1 Select the resource you wish to view in the Site View tab.

2 Click the Link View tab to display the selected resource and the 
pages that reference it.

Alternatively, you can also zoom in on a resource from the Project 
window:

1 Select the resource you wish to view in the Project window.

2 Choose the Show Site command from the Project menu.

3 In the Site View window, click the Link View tab to display the se-
lected resource and the pages that reference it.

Walking Through the Link View

You can walk through your site by clicking page and resource icons 
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440 CHAPTER 15 Designing Sites

e that lets you subdivide your 
o Sales and R & D sections. By 
while designing your site, you 
e design phase. 

onto the Project window.

2 Place the cursor in the Name text box in the Group In
name the group as desired.

3 In the Group Inspector, check the Use for generic page

4 Any page you create in the Site View will now be added to that group.

5 You can add more groups as you complete your site design and 
switch between them by selecting another group icon in the 
Project window and then checking the Use for generic pages op-
Grouping Generic Pages

If you are designing a very complex site consisting of multiple pages, 
you may find it helpful to use a structur
site by organization—for example, int
grouping the generic pages you create 
can structure your material early in th

Directing Generic Files to a File Group

To structure your site using file groups, proceed as follows:

1 Drag a File Group from the Palette 

spector and 

s checkbox.

Drag the File Group icon from the Palette…

… to add a new untitled file group to the project.

Click here to name the group…

… then check this option to have GoLive Cyber-
Studio place all generic files in that group.
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Adding Generic Links in the Site View

The Site View also supports the Point & Shoot insertion of generic 
links. Generic links are a site design tool that lets you add “place-
holder links” to your pages to edit them when you are done with 
your site design. 

To ad
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Opening Generic Pages for Editing

You can open generic pages either directly from the Site View or fr
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The Pending tab of the Project window works much like a to-do 
list. By reminding you of the links that need to be created still to 
complete the job, it assists you in building very complex sites 
without having to maintain a “checklist-style” record of your ac-
tions. 

8 Use Point & Shoot to to be  a physical link between, for example, 
selected text on the current pag  and any of the files listed in the 
Pending tab. 

9 The status of the generic link referencing that pag  will be reset 
because it has been established as a physical link now. The small 
lozeng  icon disappears from entry in the Pending tab to indicbe  
this chang  -1.status.

10 Repeat.steps 1 through 9 until all generic pag s have been turned 
into physical Web pag s and the Pending tab doesn’t.show any 
generic links anymore.
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To view Web pages with invalid or faulty pathnames in links, use the 
Files with Errors tab of the Errors window:

1 In the Errors window, click the Files with Errors tab.

2 Click the Files with Errors tab for Web pages that contain errors, 
such as broken links to other pages or resources.

The example below shows two Web pages that have lost refer-
enced files. 

Files with Errors in the Errors Window

To view invalid objects that could not be found because they were 
deleted, moved, or renamed, use the Invalid Project Objects tab of 
the Errors window:

1 Go to the Project menu and choose Show Errors to open the Errors 
window shown below.

2 Click the Invalid Project Objects tab. 

Invalid Objects in the Errors Window

The example above shows the lost file and its previous location 
relative to the home page. 
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Repairing

When an error is displayed in all three tabs of the Errors window, it is 
very likely that somebody has accidentally moved, deleted, or re-
named a file that your project needs because it is referenced by 
pages.

If error messages point at broken links coming from or going to an 
invalid object, locate the physical file to ensure that your site is fully 
intact and doesn’t contain any dead-end links.

To find a missing file, pr
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ckbox in the 
udio include 
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e Page tab of 
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roject 
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the site 
dancy 

ithin 

 part of 
 refer-
the site 

s to 
The following illustration presents the result of the three Hierarchy 
options.
Resulting Folder Structures Check the additional Honor Multi-Server Settings che

Hierarchy group of options to make GoLive CyberSt
resources from remote servers into the site folder. 

6 In the Honor “Publish” state of group of options, se

- Groups to have GoLive CyberStudio publish all g
have their Publish status checkbox enabled in th
the Reference Inspector

- Pages to have GoLive CyberStudio publish all 
have their Publish status checkbox enabled in the Pag
the Reference Inspector

7 Additionally, you can check the Publish only referenced p
files Tf
9.2 to have GoLive CyberStudio include only refer
HTML pages and media files from the current project into 
folder. This Tf
9.2 yields small sites and minimizes redun
by omitting all files that are not referenced by any page w
the site.

8 You can also check the Publish referenced files that are not
the project Tf
9.2 to have GoLive CyberStudio include all
enced HTML pages, media files, and other resources into 
folder, including non-project files.

9 Clicking the Set as default butt.2 saves the current setting
GoLive CyberStudio’s preferences.
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10 Optionally, you can open the Preferences - Project l Folder 
dialog box and edit the default folder names used for publishing 
the site.

The Preferences - Project l Folder 
Dialog Box

11
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Uploading Your Site With GoLive CyberStudio, you can easily upload or download individ-
ual Web pages or an entire Web site or open individual HTML pages 
or WebObjects declaration files on remote server volumes for edit-
ing. You can also preview and stage pages and sites before uploading 
them to your Web server. 

GoLive CyberStudio suppports most popular server platforms, in-
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over control of your Internet access to the Internet Config pro-
gram. Internet Config stores Internet addresses and Web-specific 
settings for all applications on your Macintosh that have access 
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FTP Download Preferences

The Preferences - Network - FTP Download dialog box allows you to 
assign a program on your Macintosh to files you download from the 
Web. 

The Macintosh uses a special four-character code to identify file 
types and creators, allowj
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• Checking the Create/Update MCF file on project save checkbox 
instructs GoLive CyberStudio to create a file in Apple’s proprietary 
multi-content format. This MCF file is a three-dimensional fly-
through view of your site that your audience can use as a naviga-
tion aid. You can view this file by selecting it in the Media tab of 
the Project window and opening the Content tab of the Reference 
Inspector (see page 427).

• Checking the Reparse only changed project files checkbox 
instructs GoLive CyberStudio, on opening the project, to verify 
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